DPT manual The Menus

From Archives Portal Europe Wiki
Jump to: navigation, search

There are five main menus in the Data Preparation Tool: File, Options, Actions, Windows and About.

APE DPT manual, figure 6: the five main menus of the Data Preparation Tool




the File menu

The main menu option File has five items.

APE DPT manual, figure 7: the five items of the option File


Select file or directory (shortcut: Ctrl+O or Cmd+O)

This is where you can open your files or directory (folder) to be able to process them in the tool. You have the possibility to select one or several files, or one directory. If you select a directory, the tool will import all the files located in this directory, however, subdirectories will not be included. Once you have made your selection, the files will appear in the "XML and EAD" part in the left side of the screen and then they are ready to be processed.

You can process hundreds or even thousands of files together. Once you have files available in the left part of the screen, selecting one or more files will activate the buttons in the right part of the screen and the one named List controlaccess in the bottom of the screen.

APE DPT manual, figure 8: activating the buttons by selecting one or more files


Close selected file(s) (shortcut: Ctrl+D or Cmd+D):

Using this option with one or more files selected in the left part of the screen, makes those files disappear from the list. So this is in fact an 'unselect' option.

Save selected APE file(s) (shortcut: Ctrl+S or Cmd+S):

Once one or more file have been converted and/or validated using the buttons in the right part of the screen, they have to be saved to your harddrive and you can do that using this option. The newly created files will be saved in the directory named output by default, but the Options menu allows you to change that to another location.

The names of the files will change when they are saved. If the file has been converted and validated, it is saved with the prefix apeEAD_, so in that case the name of the file in the output directory will be apeEAD_{original_name}.xml. If it is only converted and not validated yet, the prefix will be NOT_apeEAD_, so in that case the name of the file in the output directory will be: NOT_apeEAD_{original_name}.xml.

Of course, this does not affect your original files, nor wil a NOT_apeEAD_ file be overwritten by an apeEAD_ file in case you perform the conversion and validation steps as two separate actions.

Save report for selected file(s) (shortcut: Ctrl+R or Cmd+R):

Use this option in case you want to have a report on the actions you have performed in the tool.

All reports on the files processed in the tool (and selected in the list), even if the files did not pass the validation or conversion steps, are saved in one file, which is by default saved in the output directory of the tool and named: report.txt.

Quit:

Use this option in case you want to close the tool and its interface.

the Options menu

The main menu option Options has twelve items. They are meant to set up and maintain your own parameters in the tool, allowing you to apply specific rules during the processing of your files.

APE DPT manual, figure 09: the twelve items of the option Options


Country code

Here you can change the 2-letter country code, the one you had to enter at the first launch of the tool (see the Installation and launch page).

Repository code

Here you can change the identifier for your archives, the one you had to enter at the first launch of the tool (see the Installation and launch page). It’s useful when you manage more than one institution.

Digital object type / Rights

This option allows you to add specific information on the type and on the rights of digital objects your data link to, mandatory for Europeana and strongly recommended for the Archives portal Europe. Please be aware of the fact that the choices you make here will be applied to all files you process in the tool, untill you change them.

APE DPT manual, figure 10: assign digital object type / rights


The digital object type indicates whether the digitised archives are Text, Image, Sound, Video or 3D. If you don't use this option, the default value will be Unspecified. This option is used within the Archives Portal Europe for refining the search results. The values chosen are saved in your apeEAD XML files after you convert them. The chosen digital object type will then be available inside your apeEAD XML file within each <dao/> element as attribute @xlink:role. In case, your local data already contains this information, you can indicate that this information has to be kept and not overruled.

Note: Converting the file and then choosing a type will NOT change the type inside the newly created file. A new conversion is needed.

This rights information dialogue screen allows you to also add default rights statements for your metadata, so for your finding aids. The proper rights information can be chosen from a dropdown list containing the main licenses in use for cultural heritage objects and metadata. Finally the rights information can be completed by adding a description and the name of the rights holder.

General options for EDM conversion

Using this option you can fine-tune some parameters for the apeEAD to EDM conversion. You can specify by default the source of the identifiers as well as the base URL for the landing pages other than the digital objects.

APE DPT manual, figure 11: specify some EDM conversion parameters


List of date conversion rules

This option offers via a dialogue box the possibility to tell the tool which rules should be applied during the conversion of dates in your files, especially in case of normalising textual dates. In the left column, you indicate the values that will be found in your original files and in the right column, you indicate how these values should be converted (after which those values will be used in your converted files).

APE DPT manual, figure 12: possibility to specify data conversion rules


For instance you can indicate that 18th century will be converted in 1701-1800, circa 1877 in 1877, or in 1876-1878 etc. These conversion rules can be saved to be re-used later on. You can modify them as often as needed.

Note that this is an extra possibility, to complete the normalisation of dates already done during the conversion by the tool (see annex 2 for the full list of these conversion rules). These added rules have priority over the default rules.

Use own stylesheet

This option allows you to use your own style sheet (XSLT) in order to run your conversions instead of the default one. When using this option a dialogue screen opens where you can select a style sheet from your anywhere on your harddrive to copy it in the xsl directory of the tool. The stylesheet then appears in the list of the summary tab and can be chosen to convert your files.

Use own schema

This option allows you to use your own schema (this must a valid XSD file). When using this option a dialogue screen opens where you can select a schema from your anywhere on your harddrive to copy it in the xsl directory of the tool. The schema then appears in the list of the summary tab.

Choose default stylesheet

Either: default-apeEAD.xsl or: default-apeEAC-CPF.xsl; by default the style sheet selected for newly imported files is the default-apeEAD style sheet, assuming you want to convert finding aids most of the time. Use this option if you wish to use the default-apeEAC-CPF style sheet on a regular basis, so are using the tool to convert EAC-CPF records most of the time.

APE DPT manual, figure 13: choose default stylesheet


Choose default schema

This option lists the different possibilities offered by the tool to validate the files: apeEAD, EAD 2002, EAD 3, EAD 2002 DTD, apeEAC-CPF, EAC-CPF, EAG 2012, apeMETS, apeMETS Rights, apeMETS Xlink. By default the system sets the data type to apeEAD files, you can change this by using this option.

APE DPT manual, figure 14: choose default schema


Checks when loading files

This option allows you to tell the tool to check if the files that you are uploading are valid XML files. Be careful with this option because it might take a lot of time if you have to upload a large amount of files. Before displaying the files in the list, the tool parses them and rejects the non XML files. For each file, a pop-up window warns you and allows you to copy the error message.

APE DPT manual, figure 15: activate checks when loading files


Default folder for saved files

The default directory or folder where the tool saves your converted files as well as the report on the XML quality is the output folder of the tool (one of the six folders mentioned on the page: Installation and launch of the tool). This option allows you to change this default folder into another folder on your harddrive.

Languages

The tool is available in six languages: Dutch, English, French, German, Greek and Hungarian. The tool will open in the language of your operating system if it is Dutch, French, German, Greek or Hungarian and if your language is not found it will roll back to English. This option offers you the possibility to change the language.

APE DPT manual, figure 16


the Actions menu

The main menu option Actions has four items.

APE DPT manual, figure 17: the four items of the option Actions


Validate (shortcut: Ctrl+N or Cmd+N)

This option does the same as the Validate button in the main summary tab.

Convert (shortcut: Ctrl+M or Cmd+M)

This item does the same as the Convert button in the main summary tab.

apeEAC-CPF

The option apeEAC-CPF has only one submenu which opens a form in a pop-up window in which you can create an apeEAD-CPF record.

APE DPT manual, figure 18: create apeEAC-CPF record


First you have to choose which kind of entity you are going to describe: a person, a family, or a corporate body, as well as the language and script for your description:

APE DPT manual, figure 19: apeEAC-CPF record creation, choose the entity type


Then the corresponding form is displayed. The form is subdivided in four tabs that have to be completed and correspond to the ISAAR-CPF standard: Identity, Description, Relations, Control.

APE DPT manual, figure 20: apeEAC-CPF record creation form


EAG 2012

This option has two submenus: Select an existing EAG(2012) file and Create a new EAG2012 file.

APE DPT manual, figure 22: select/create EAG(2012) file


  • Select an existing EAG(2012) file allows you to open the file that you want to process in the tool (completing or correcting existing elements for instance).
  • Create a new EAG2012 file opens a form in a pop-up Window.
APE DPT manual, figure 22: EAG2012 record creation form


The form is subdivided in seven tabs that have to be completed following the logical order of the ISDIAH standard: Your institution, Identity, Contact, Access and Services, Description, Control, Relations.

You move from one tab to the other by clicking on the next/previous buttons. The tab Your institution includes all mandatory elements, plus some optional elements. Once saved, the EAG file is added to the files in the list and can be validated afterwards.

the Windows menu

The main menu option Windows has five items.

APE DPT manual, figure 23: the five items of the option Windows


Via these items you can quickly go to corresponding five tabs in the right part of the screen, which give you detailed information on the status of the file(s), in the left part of the screen:

  • Summary (shortcut: Ctrl+1 or Cmd+1), let's you jump to the Summary tab
  • Validation (shortcut: Ctrl+2 or Cmd+2), let's you jump to the Validation tab
  • Conversion (shortcut: Ctrl+3 or Cmd+3), let's you jump to the Conversion tab
  • Europeana conversion (shortcut: Ctrl+4 or Cmd+4), let's you jump to the Europeana conversion tab
  • Edition (shortcut: Ctrl+5 or Cmd+5), let's you jump to the Edition tab

In order to change to a tab, you can either click on the tab label, select the tab label in this menu or its shortcut.

the About menu

The main menu option About has two items.

APE DPT manual, figure 24: the two items of the option About


Visit project website

This option opens a page in your browser (for which you will need an internet connection) to access the APEx project website (www.apex-project.eu).

APE DPT v2.0.x

This option indicates the version of the DPT you are working with. At the opening of the tool, an automatic check for updates is performed. At the moment his item shows the current version of the tool: APE DPT v2.6.1.